164 Phone: 765-288-1893 800-475-6277 KnappSupply.com 9/2026 WELDBEND Carbon Steel Reducing Tees 150# WELDBEND Carbon Steel Extra Heavy Fittings UniFlange For Ductile Iron Catalog Description Unit Price 1 CSRT001 150# CS RED TEE 2X1" WELD FITTINGS EA 26.58 CSRT002 150# CS RED TEE 2X1-1/4" WELD FITTINGS EA 26.58 CSRT003 150# CS RED TEE 2X1-1/2" WELD FITTINGS EA 26.58 CSRT004 150# CS RED TEE 2-1/2X1-1/4" WELD FITTINGS EA 29.11 CSRT005 150# CS RED TEE 2-1/2X1-1/2" WELD FITTINGS EA 29.11 CSRT006 150# CS RED TEE 2-1/2X2" WELD FITTINGS EA 29.11 CSRT007 150# CS RED TEE 3X1-1/2" WELD FITTINGS EA 28.39 CSRT008 150# CS RED TEE 3X2" WELD FITTINGS EA 28.39 CSRT009 150# CS RED TEE 3X2-1/2" WELD FITTINGS EA 28.39 CSRT010 150# CS RED TEE 4X2" WELD FITTINGS EA 36.00 CSRT011 150# CS RED TEE 4X2-1/2" WELD FITTINGS EA 36.00 CSRT012 150# CS RED TEE 4X3" WELD FITTINGS EA 36.00 CSRT013 150# CS RED TEE 5X2-1/2" WELD FITTINGS EA 77.81 CSRT014 150# CS RED TEE 5X3" WELD FITTINGS EA 77.81 CSRT015 150# CS RED TEE 5X4" WELD FITTINGS EA 77.81 CSRT016 150# CS RED TEE 6X3" WELD FITTINGS EA 70.20 CSRT017 150# CS RED TEE 6X4" WELD FITTINGS EA 70.20 CSRT018 150# CS RED TEE 6X5" WELD FITTINGS EA 70.20 CSRT019 150# CS RED TEE 8X4" WELD FITTINGS EA 133.60 CSRT020 150# CS RED TEE 8X5" WELD FITTINGS EA 133.60 CSRT021 150# CS RED TEE 8X6" WELD FITTINGS EA 133.60 CSRT022 150# CS RED TEE 10X5" WELD FITTINGS EA 246.75 CSRT023 150# CS RED TEE 10X6" WELD FITTINGS EA 246.75 CSRT024 150# CS RED TEE 10X8" WELD FITTINGS EA 246.75 CSRT025 150# CS RED TEE 12X6" WELD FITTINGS EA 363.84 CSRT026 150# CS RED TEE 12X8" WELD FITTINGS EA 363.84 CSRT027 150# CS RED TEE 12X10" WELD FITTINGS EA 363.84 Catalog Description Unit Price 1 XHCSSR200 2 XH CS SHORT RADIUS 90 ELBOW EA 28.39 XHCSLR200 2 XH CS LONG RADIUS 90 ELBOW EA 8.00 XHCS45200 2 XH CS 45 ELBOW EA 8.38 XHCST200 2 XH CS WELD TEE EA 17.30 Catalog Description Unit Price 1 RFC-203-D 3 UNIFLANGE FOR DUCTILE (RED) EA 89.04 RFC-204-D 4 UNIFLANGE FOR DUCTILE (RED) EA 120.11 RFC-206-D 6 UNIFLANGE FOR DUCTILE (RED) EA 129.36 RFC-208-D 8 UNIFLANGE FOR DUCTILE (RED) EA 179.76 RFC-210-D 10 UNIFLANGE FOR DUCTILE (RED) EA 322.56 RFC-212-D 12 UNIFLANGE FOR DUCTILE (RED) EA 376.32 RFS-201-S 2 UNIFLANGE FOR STEEL (GREEN) EA 103.33 RFS-202-S 2-1/2 UNIFLANGE STEEL (GREEN) EA 103.33 RFS-203-S 3 UNIFLANGE FOR STEEL (GREEN) EA 131.89 RFS-204-S 4 UNIFLANGE FOR STEEL (GREEN) EA 139.44 RFS-205-S 5 UNIFLANGE FOR STEEL (GREEN) EA 287.28 RFS-206-S 6 UNIFLANGE FOR STEEL (GREEN) EA 174.72 RFS-208-S 8 UNIFLANGE FOR STEEL (GREEN) EA 192.36 RFS-210-S 10 UNIFLANGE FOR STEEL (GREEN) EA 391.44 RFS-212-S 12 UNIFLANGE FOR STEEL (GREEN) EA 462.00 Weldbend Catalog Click on RED Catalog #’s for additional information.
RkJQdWJsaXNoZXIy NTQ1NzI2